Supported Versions

Vuforia Engine supports the following operating system, tool, and device versions for developing apps with the Vuforia Engine platform.

Mobile Devices

Device OS

Developer Tools

Fusion Provider

Android (1) 5.1.1+ NDK r20+ ARCore 1.10+
Gradle 5.1.1+
Android SDK Build Tools 28.0.3+
Android Studio 3.6.x+
Unity Editor 2019.4.0+
iOS (2) 12+ Xcode 11.5+ ARKit
Unity Editor 2019.4.0+

Windows (3)

10 Visual Studio 2019 version 16.5+  
Unity Editor 2019.4.0+

Lumin OS

  Lumin SDK 0.24.1+ N/A
Lumin OS 0.98.11+
Unity Editor 2019.4.0+
1. ARM 32 & 64-bit
2. 64-bit, Native and Bitcode
3. 32 & 64-bit Universal Windows Platform 1809 (10.0.17763) or Later; Intel 32 & 64-bit, ARM 64-bit.

Vuforia Engine Tools

App

Devices

OS Version

Object Scanner

  • Samsung Galaxy S10+
  • Samsung Galaxy S10
  • Samsung Galaxy S9+
  • Samsung Galaxy S9
  • Samsung Galaxy S8
  • Samsung Galaxy S7
  • Google Pixel 2
  • Xiaomi Redmi Note 7
  • Latest supported OS on the device
Area Target Generator (ATG)    
  • 64-bit, Windows 10 (1809) or later.
  • 64-bit, macOS 10.15 (Catalina) or later.  
Model Target Generator (MTG)    
  • 64-bit, Windows 10 (1809) or later.
  • 64-bit, macOS 10.15 (Catalina) or later.  
Vuforia Area Target Creator App
  • iPad Pro 11” (2nd generation)
  • iPad Pro 12.9” (4th generation)
  • iPadOS 14

Vuforia Engine Features

Feature

Requirements

Model Targets in Unity Play Mode

  • Windows - GPU with Direct X 11 feature-level 10 support
  • MacOS - 10.13+, GPU with Metal Support
Ground Plane / Device Tracker

iOS Devices

Android Devices

  • Android Version: 6.0 (Marshmallow) or later
  • ARCore or VISLAM support via Vuforia Fusion

UWP Devices

  • VISLAM support via Vuforia Fusion
  • HoloLens 1 and HoloLens 2 do not support Ground Plane. For equivalent functionality, please use SDK provided by OEM

Lumin Devices

  • Ground Plane not supported. For equivalent functionality, please use the SDK provided by OEM
Area Targets

iOS Devices

Android Devices

  • Android Version: 6.0 (Marshmallow) or later
  • ARCore support via Vuforia Fusion

UWP Devices

  • Support for HoloLens 1 and HoloLens 2 only

Lumin Devices

  • Not supported
Model Targets

iOS Devices

Android Devices

  • Android Version: 6.0 (Marshmallow) or later
  • ARCore or VISLAM support via Vuforia Fusion

UWP Devices

Lumin Devices

  • Beta support only

Graphics API Support

Android

iOS

Windows

  • OpenGL ES 2.0
  • OpenGL ES 3.x
  • Vulkan(1)
  • OpenGL ES 3.x
  • Metal 1.0+
  • DirectX 11 on Windows 10

(1) Support in Unity only