Supported Versions

Vuforia Engine supports the following operating system, tool, and device versions for developing apps with the Vuforia Engine platform.

Mobile Devices

Device OS

Developer Tools

Fusion Provider

Android (1) 8.0 NDK r21+

ARCore. Minimum version 1.24, Recommended version 1.32.

Gradle 6.7.1+
Android SDK Build Tools 30.0.3+
Android Studio 2020.3+
Unity Editor 2020.3.0+
iOS (2) 14+ Xcode 13.2.1+ ARKit
Unity Editor 2020.3.0+

Windows (3)

10 Visual Studio 2019 version 16.10+  
Unity Editor 2020.3.0+

Lumin OS

Magic Leap 1 (deprecated) N/A
Lumin SDK 0.26.0+
Lumin OS 0.98.30+
Unity Editor 2020.3.0+
Magic Leap 2
Lumin SDK 0.53.2+
Lumin OS B3E.220721.07-R.026_user_secure
Unity Editor (minimum/recommended) Unity 2022.2.0b4
MagicLeap XR Plugin (recommended) 7.0.0-exp3
1. ARM 32 & 64-bit
2. 64-bit, Native, and Bitcode (Deprecated)
3. 32 & 64-bit Universal Windows Platform 1809 (10.0.17763) or Later; Intel 32 & 64-bit, ARM 64-bit. Intel 32-bit is deprecated and will be removed in a future release.

Vuforia Engine Tools

App

Devices

OS Version

Area Target Generator (ATG)    
  • 64-bit, Windows 10 (1809) or later.
  • 64-bit, macOS 10.15 (Catalina) or later.  
Model Target Generator (MTG)    
  • 64-bit, Windows 10 (1809) or later.
  • 64-bit, macOS 10.15 (Catalina) or later.  
Offline Model Target Generator  
  • 64-bit, Windows 10 (1809) or later.
  • Linux Ubuntu systems 20.04 or later.
Vuforia Area Target Creator App

iPhone and iPad models with a built-in LiDAR device as listed below or released later:

  • iPhone 12 Pro
  • iPhone 12 Pro Max
  • iPhone 13 Pro
  • iPhone 13 Pro Max
  • iPad Pro 11” (2nd & 3rd generation)
  • iPad Pro 12.9” (4th & 5th generation)

 

On all other iPhone/iPad models the app can be used to test captured Area Targets

  • iOS 14 or later
  • iPadOS 14 or later

Vuforia Engine Features

Feature

Requirements

Model Targets in Unity Play Mode

  • Windows - GPU with Direct X 11 feature-level 10 support
  • MacOS - 10.15+, GPU with Metal Support
Ground Plane /Device Tracking

iOS Devices

Android Devices

  • Android Version: 8.0 (Oreo) or later
  • ARCore or VISLAM support via Vuforia Fusion

UWP Devices

  • VISLAM support via Vuforia Fusion
  • HoloLens 2 does not support Ground Plane. For equivalent functionality, please use SDK provided by OEM

Magic Leap 1 and 2

  • Ground Plane not supported. For equivalent functionality, please use the SDK provided by OEM
Area Targets

iOS Devices

Android Devices

  • Android Version: 8.0 (Oreo) or later
  • ARCore support via Vuforia Fusion

UWP Devices

  • Supported on HoloLens 2

Magic Leap 1 and 2

  • Supported
Area Targets Capture API

iOS Devices

  • Supported only on devices with LiDAR sensor.

Magic Leap 1 and 2

  • Supported
Model Targets

iOS Devices

Android Devices

  • Android Version: 8.0 (Oreo) or later
  • ARCore or VISLAM support via Vuforia Fusion

UWP Devices

Magic Leap 1 and 2

  • Supported

Graphics API Support

Android

iOS

Windows

  • OpenGL ES 3.x
  • Vulkan(1)
  • OpenGL ES 3.x
  • Metal 1.0+
  • DirectX 11 on Windows 10 and 11

(1) Experimental support in Unity only